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Publishing with iBooks Author 

 
WHAT IS A eBOOK? 

 
The Kindle accepts Mobi ad PDF, but not EPUB.  iBooks accepts EPUB and PDF, not Mobi.  Apple 
allows users to use Author to create eBook using its own iBook publishing platform - .iBooks.  

  

LEARNING OBJECTIVES 
 Requirements for publishing with iBooks Author 

 Download iBooks Author to computer 

 Basic interface, template chooser and tools 

 Page Layout 

 Interactivity and widgets 

 Share options 

 

What do you Need to create an iBook? 
1. Computer with Mac OS Lion 
2. iPad 
3. iBooks Author application 

 

Template Chooser 
The first thing you see when you open iBooks Author is the Template Choose.  There are 6 templates 
for you to choose for the general look of your book: Basics, Contemporary, Modern Type, Classic, 
Editorial, and Craft.  Each template has its own preset styles, graphics and text layout. You can 
change most parts of the template, but not all.  Templates are already filled with placeholder 
images and text.   You can also choose the Basic blank template to start creating your book from 
scratch. 
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Editing Window 
 
The editing window consists of the Toolbar, the Format Bar, and your book pages. 
 

The Toolbar 
 

 
 
A few things to consider:  Rulers, Author > Preferences > Rulers, Show/Hider Invisibles, 
Show/Hide Layout Boundaries 
 

Orientation 
 
Portrait mode – very rigid layout; scrollable text; all widgets appear as small clickable thumbnails 
in the left margin.  Text scrolls up and down like a web page.  Some graphics and text boxes will 
not show up at all in this view.  Layout in Landscape format, you will get the portrait layout for free. 
 
Landscape mode – all widgets are interacting directly on the page. 
 

Inspector  
 
Every object has an inspector to help you customize and fine-tune your object. 
 

The Format Bar 
 
Format bar is just right below the Toolbar, which contains many options depending on what object 
you have selected. For example, if you are selecting text, you will have options on fonts, background 
colors, font style, alignment, line spacing etc.  
 

 
 

The Book Menu 
 
The Book menu consists of title page, intro media, table of contents, and glossary, followed by a 
book outline or page thumbnails depending on what you desire as View option.  
 
The intro media allows you to add an image, audio file, or movie to introduce your book.  The audio 
or movie will play automatically if you choose to include one. 
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Table of Content 
Table of contents is generated automatically for each chapter of the book as you are compiling 
it.  You cannot edit any of the auto-generated text on the TOC, but you can add new text boxes 
and a short paragraph to describe the chapter.  
 
The gray boxes at the bottom of each of the TOC page will be filled with icons of the first page of 
each chapter when you export your book, giving users a visual view for easy navigation.  
 
Use the little dots at the bottom of the screen to switch to the TOC pages for different chapters. 
 

           
 

           
 

Glossary 
Glossary can be easily created by double-clicking to select a word, then right-click/Cmd+click to 
choose ‘Create New Glossary Term from Selection’ from the content menu.  The word will then 
turned bold indicating that it has been added to the Glossary. You can also add a new glossary 
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terms from the Glossary toolbar by typing the term and clicking Add Term.  Make sure you have to 
select the word first. 
 
To define a term, select the word for a glossary term and then add a dictionary definition. 
 
The Index section tells you where you can find a term in your book.  It automatically links to the place 
in the book where you originally set a word into a glossary term, but you can also add as many 
index entries to other locations as you want.  To do this, make sure that you have the Glossary 
toolbar  displayed, and then select the word that you want to add a link to, choose the glossary term 
from the ’Index link for’ drop-down menu, and click Add Link. You can use the ‘Find term’ button 
from the Glossary to search the book for every occurrence of a glossary term, and add Index Links 
to any or all of the found results too. Study cards can be created on your iPad Preview with glossary 
terms. 

  

Document Inspector 
 
Couple of things to note here…  
 

1. If you don’t want your readers to be able to read your book in 
portrait mode, turn on the ‘Disable portrait orientation’. 

2. Turn off Hyphenate if you want your words to not break across 
lines. 

3. If you wish to password-protect your file, check the box ‘Require 
Password to Open’. 

 

Page Layout 
 
PDF are fixed layout formats, while EPUB and Mobi are fluid formats 
allowing text to reflow to fit the container of the text.  iBooks Author gives 
freedom to the user further by allowing them to read from the iPad in 
either portrait or landscape view. 
 
Note the differences as you explore between the two views in respect to 
the following elements: 
Page numbering, content presentation, caption, image, interactivity, video, 
TOC. 
 

Formatting Text 
 

Define placeholder text 
Format > Advanced > Define as Placeholder Text. 
 

Add Text  
Choose Insert > Chapter from Pages or Word Document.  Choose one of the layout options when 
you choose the file to import.  Author will use the document filename as the title of the chapter or 
section, which you will have to change later. 
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When importing text, choose ‘Preserve document paragraph styles on import’ if you want to keep 
the styles you have already formatted in Word or Pages.   
 
Author will use the document filename as the title of the chapter or section, and you can change it 
later as desired. 
 
Author always leave the first paragraph filled with placeholder text even after you have imported 
text for your new chapter.  It is waiting for you to replace it with an introductory paragraph.   
 

Columns and Page breaks 
Choose the text where you want it to break and choose Insert > Column Breaks or Page Breaks.  
To delete a column or page break, click in the text immediately following the break and hit the 
Delete key. 
 

Sidebars 
Sidebars are usually text in a separate box set away from the main text. Each template has its own 
matching sidebar boxes created for you, but you can create your own too. 
 
To add a sidebar, you can do one of the followings: 

1. Insert a new page that includes the sidebar from the template. 
2. Copy a sidebar from another location in your book and paste it in the desired place. 

 
To create your own sidebar from scratch, simply add a new text box and apply a custom color, 
background, stroke, and text.  Once you have the sidebar created, you can choose Format > Copy 
Graphic Style and then apply this style to another image using Format > Paste Graphic Style. 
 
Note:  Sidebar boxes disappear when users switch to portrait orientation.  To avoid this, you must 
turn them into widgets by adding a label.   
 
Widgets can be formatted by adding borders and backgrounds, styles, text and captions.  From the 
Widget panel > under Layout tab >check the box next to Title.  Choose None for Label.  Turn 
caption or background on if desired. 
 

Tables 
Click the Table button in the toolbar to add a table to your book.  By default, the new table is set in 
the middle of your page, and set to float so that you can drag and drop it anywhere you like.  The 
Inline button in the Format bar will allow you to put the table in the flow of the text. 
 

Adding Pages 
To add extra pages to your book manually, you can click the page thumbnail that you want to add 
pages after, and then click the Add Pages button in the top left of the Toolbar. Choose the page 
layout style you want for your new page.   
 
Note: You WILL NOT be able to move the page around once it’s there, so make sure you add 
them in the correct spot. 
 

Adding Sections and Chapters 
This works the same as adding pages.  However, unlike individual pages, you can reorder the 
sections and chapters by dragging them around. 
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Change Page Layout 
You can change layout for any page, sections or chapters.  First select the page you want to change, 
and then click the little arrow that appears to the right, and choose from the list of layouts. 
 
Choose View > Show Page Layout to see all layouts. 
 

Page Numbering 
All page numbering is based on the landscape orientation. In iBooks Author, you can see page 
numbers in the Book pane, to the left of each thumbnail while in the landscape orientation. In the 
finished book, page numbers appear in the lower-right corner of the page in both orientations. 
Chapters, sections, and pages are automatically numbered. (Chapters and sections are numbered 
separately from one another.) By default, these items are numbered sequentially throughout the entire 
book, but you can make a section or page start with a specific number. 
 
Change section or page numbers  

1. Select the chapter or section in the Book pane.  
2. If the Layout inspector isn’t open, click Inspector in the 

toolbar and click the Layout Inspector button.  
3. In the Layout inspector, click Numbering. 
4. Do any of the following: 

 

 To number sections based on their order within 
a chapter or book: Choose an option from the 
Section Numbers pop-up menu. You can 
number sections continuously throughout the 
book, or you can number them on a per-
chapter basis. For example, if sections are 
numbered by chapter, Section 4.2 identifies the 
second section in the fourth chapter.  

 To remove numbering from a chapter or 
section: Choose None from the Section 
Numbers pop-up menu.  

 To continue numbering from the previous section: Select “Continue numbering.”  

 To start the section or page with a specific number: Select “Start at” and enter a 
number.  

 To change the numbering format: Choose an option from the Format pop-up menu. 
 

Images 
To add an image, simply drag and drop your image into your page.  While you are selecting your 
image, the Format Bar changes to cater to your selection.  You can then add a border, stroke etc. to 
your image. 
 

Graphic Inspector 
Graphic inspector allows you to add a background color to your selected object such as shapes or 
text boxes; add strokes, style, and shadow and adjust opacity. 
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Levels 

Click the levels button to open the Adjust Image window where you can adjust the color balance, 
sharpen your image, enhance brightness, contrasts, saturation, temperature, exposure etc. 
 

Mask 
Masking shows only a portion of the image.  Click Format > Image > Mask or Mask with Shape. 
 

Anchors 
Anchored image is better than flowing an image.  It ties you image to a specific point within the text 
on the same page while you still being to move it. 
 

Figures 
You can turn an image into a numbered figure in the book.  Select the image > choose Widget 
Inspector > turn on Title checkbox, choose Figure from the Label drop-down menu. 
 

Charts 
Click the Charts button in the toolbar or go to Insert > Chart to add a chart to your page. 
 

Widgets 
Widgets are special sidebars with different contents.  Use them to add image galleries, slideshows, 
video or audio elements into your page. 

 
Note: Widgets don’t appear on the first page of a chapter in portrait orientation. 
 

Gallery 
You can use the Gallery widget to put multiple images into a photo gallery.  Click Widgets in the 
Toolbar > and choose Gallery. Author adds an empty sidebar to your page with placeholder text.  
Drag and keep adding images on top of the picture icon.  
 
Add/remove images - Use the Interaction tab to add or remove images from your Gallery. 
 
Title - You can only add one title to the Gallery sidebar, but you can add different captions for each 
image. 
 

Media 
You can add movie or audio file to the page via the Widgets in the toolbar.  Click Widgets in the 
Toolbar > and choose Media. Author will add a box in the middle of your page.  You can then drag 
the desired file from the Finder and pop it to your page. 
 
Movie files (.m4v) – select the movie file (.mov) in Quicktime and choose File > Export.  Choose 
‘ipad, iPhone and Apple TV’ format. Click Export.  The movie will be saved as m4v format.  You can 
now drag and drop your movie to your page.  Position it and adjust the size of the video as desired. 
 
Audio files (.m4a) – open the file in iTunes, right-click or control-click on the file name and choose 
‘Create AAC version’ from the context menu. 
  
Note: Author supports only one movie format – .m4v and one audio format - .m4a. Movies can be 
pretty big files, which affects loading time on the iPad and will take up more storage space. Author 
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does NOT embed any videos, movies or images into your pages.  Instead, it saves the files in a 
special folder and links to them. 
  

Review 
Quiz questions can be created using Author – basic MC with image, adding text labels, adding 
image labels. Click Widgets in the Toolbar > and choose Review. 
 
Use the + or – buttons to add or delete questions.  Drag the image from the Finder or from the 
Media Browser into the image box if you want to add images to your questions. 
 

Keynote  
Click Widgets in the Toolbar > and choose Keynote.  Author will add a box in the middle of your 
page labeled Presentation.  Drag the file into the box.   
 
Note: Author only accepts Keynote files, not PowerPoint.  But Keynote can open a PowerPoint file 
and convert it for you – simply right-click your PowerPoint file in Finder and choose Open with 
Keynote.  Transitions, timings and voice-over narration in your presentation will not be supported on 
your iPad iBook. 
 

Interactive Image 
Click Widgets in the Toolbar > and choose Interactive Image.  Author gives you two interactive 
labels, and you can delete one if you wish.  Drag your image into the middle of the page, and then 
start to add interactivity. 
 
Click a label and Author will zoom into a random place on your image.  Adjust the zoom slider and 
drag your image until it is right.  Click to edit the text label and description as desired, and click ‘Set 
View’ after you are done. Turn on the ‘Show transport controls’ if you wish the users to interact with 
the page in a different way. 
 

3D 
Add 3D collada (.dae) files to your book for a 3D experience. Collada files can be created with 
Google Sketchup Pro.  Click Widgets in the Toolbar > and choose 3D.  Drag the box wherever you 
like and drag your file into it. Turn on the ‘Auto-rotate object when idle’ option if you want the 
object to spin around even when the users are not using it. 
 

HTML 
Dashcode comes installed on all new Macs and you can check out how to build your own Dashcode 
applications using HTML on http://bit/ly/yEqA1B.  A Dashcode Example:  Mac HD > Library  > 
Widgets > calculator. 

 

Layouts 
Apply changes to existing layout 

Choose View > Show Layouts to display all different layout options.  Click one to open it and make 
a few changes to it if you like.  Then click the big red Apply Changes button. Doing so will also 
change the existing pages you use this layout in the book. 
 

Create a new layout 
If you want to make a new layout from scratch, first you select a type of layout – chapter, section or 
page.  Then in the Toolbar, click the Add layout button.  A new page is now added to that group.  

http://bit/ly/yEqA1B
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Click twice on the name of the new page to rename it.  You can add as much as you like to a layout 
page, and fill it with boxes, colors, page number etc.  If you want to change your layout elements on 
a page-to-page basis, you need to select the item and check the ‘Editable on pages using this 
layout’ checkbox in the Layout Inspector. 
 
Text boxes in your Layout pages helps to flow text as needed.  For each text box, turn on ‘Editable 
on pages using this layout’ in the Layout Inspector.  You will also need to tag the text box.  These 
tags allow Author to know what kind of text goes into each box.  If there’s overset text, Author will 
find the next text box with the same tag and flow the rest of your text in there.  Therefore, you can 
only use one tag once per page.  Any linked text boxes share the same tag. 
 

Save new layout as Template 
If you have heavily customized a layout, you can then save it as a new template and use if for future 
books.  Choose File > Save as Template.  Give it a unique name and Save.  Next time when you 
open Author, you will see the template listed in the Template Chooser. 
 
If you messed up on a layout and want to revert back to the original layout, you can move your 
mouse over the page thumbnail in the Book menu and then click the little arrow that appears to the 
right.  Choose ‘Reapply Layout’.  This does not delete the additional stuff you have added to the 
layout such as text, sidebars or images etc. 
 

Glossary and Study Cards 
1. View > Show Glossary Toolbar. 
2. Select a term in your text. 
3. Click the Add Term button. The glossary term is now bolded. 
4. Click on Glossary on the left sidebar and you will see the term listed on the right.  Replace 

the placeholder definition for the term. 
5. From your iPad, open your iBook.  Tap on the glossary term to see the definition. 
6. Click on Glossary index button from the pop-up window to review a list of all glossary 

entries.  Click Done to exit screen. 
7. To use glossary entries to study, go back on the page where the glossary term is.  Tap once 

on the page and click the Study Card icon. 
8. Click on the Study Cards button on top left of the right column. 
9. Click on the Flip icon to review the definition.  Click Done twice to go back to the page. 

  

Save our Book 
Changes you make to your documents are saved automatically. You need to save a document only 
once, to name it and decide where to store it. After you save a document, you can save additional 
versions of the document as you use iBooks Author. If you don’t like the changes you made to your 
document, you can browse a timeline of all saved document versions and revert to one of your 
previous versions. You can also undo your changes by choosing Edit > Undo multiple times. You 
don’t need to save before closing iBooks Author. If you have multiple documents open when you 
close iBooks Author, all the documents open the next time you open iBooks Author. You can open a 
specific book by double-clicking it in the Finder or dragging the file to the iBooks Author icon in the 
Dock. 
 

Save a specific version of a document 
Choose File > Save a Version. 
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You must have saved the document at least once before you can save a version. Versions saved this 
way are called archived versions. 
 

Browse archived versions of a document 
1. Open the document for which you want to access older versions, and hold your pointer over 

the name of the document at the top of the main window. 
2. Click the triangle that appears and choose Browse All Versions from the pop-up menu. 
3. To move back in time and see older versions of the document, move your pointer over the 

timeline on the right side of the screen. 
4. When you find a version you want to look at, click it. 

 
To restore an older version 

Click Restore when the version you want is on top. The restored document appears on your desktop, 
replacing the last version you were working on. That version is saved in the timeline if you want to 
retrieve it. 
 

Save a copy of a document with a new name 
1. Choose File > Duplicate. 
2. Choose File > Save. 

 
Preview your Book 

Follow the following steps to preview your book: 
 

1. You must install iBooks 2.0 on your iPad available from the App Store. 
2. Use a USB cord to connect between your iPad to your Mac. 
3. Open iBooks on you iPad. 
4. In Author, click the Preview icon. 
 

Share your Book 
Export 

1. Notice that your original file is a .iba extension, which is editable in Author. 
2. To share your book, choose File > Export > choose iBooks. 
3. Or, Share > Export. 
4. Click Next, and then choose file destination. 
5. Your file is now a .ibook extension to be viewed on your iPad. 
6. To share privately, one option is to drop it to your Dropbox or to the Cloud. 
7. iPad users can now access your shared Dropbox folder on their ipads and open the file in 

iBooks via the ‘Open with iBooks’ option. 
8. Users can also drag and drop the .ibook file from their computer to their iPad via a 

connector cable. 
 

Email 
Choose Share > Send via Mail to export your iBooks Author file for Mac, iBooks for iPad file, or a 
PDF.  PDF files will not support the interactivity the Book offers. 
 

Submitting your Book to the iBookstore 
Choose Publish > choose ‘Learn more about publishing to the iBookstore’. Choose an account that 
meets your needs. 
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 Setup an account in iTunes Connect. 

 Download and install iTunes Producer via iTunes Connect. 

 Establish a contract with Apple. 

 Prepare a sample version of your book. 

 Publish to the iBookstore. 
 

Different ISBN are required of the same book in digital and print versions.  You can purchase ISBN 
from Bowler website service, or Wiley. 
 
Meeting Apple requirements and submitting an application to apply for a Paid Books Account does 
not automatically guarantee that you have a contract with Apple.  Apple can reject your application 
for different reasons.  Upon that, they might refer you to an Apple-approved aggregator, which has 
its own application process and distribution fees and setup process. The process takes a couple of 
days, and you will be notified via email or a notification via iTunes Connect if there is a problem 
with your submission. 
 
For every sale, Apple takes 30% you make through the iBookstore.  Also, Apple prohibits the sale of 
files created with Author in any channel other than the iBookstore. 
 

Creating the Sample Book 
You can use Copy and Paste at the section or chapter level to create your sample book as an entire 
new book. 
 
Once you are done, you can choose File > Export and save it as name.ibooks. 
 

Package your Book with iTunes Producer 
To load your book to the iBookstore, you need to use a separate application called iTunes 
Producer, which you will only have access to after you have set up your Paid or Free Books account. 
 

Free Books Account 
There’s no need for an ISBN for free books account.  However, you might want to add screenshots, 
book description, and metadata to build searchability and marketability of your iBook. 
 
Note:  The iTunes Producer User Guide is very helpful and can be downloaded from the ‘Deliver 
your Content’ section in iTunes Connect.  There are also training videos and other resources 
available for you in Apple’s documentation. 
 

Resources 
 
YouTube Video on Publishing to Apple store - http://www.youtube.com/watch?v=N8Tx3NmRgz8 
ISBN number purchase – try http://epubbud.com 

http://www.youtube.com/watch?v=N8Tx3NmRgz8

